Core Disabled Issue

Gunbot Shop Gunbot Forum Technical Support Core Disabled Issue

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #11418
    Paul Halliday
    Participant
      • Posts: 24
      • Novice

      For various reasons, I’ve not used Gunbot for a few months but today I started it up again. I am on a Contabo VPS and using Gunbot v23.04. I updated my API keys on Okex and clicked open on the gunthy-win file. The command window opens with Loading config… then GUI Server deployed : localhost 5000.   However when I load dashboard and try to trade it won’t work – I see message “Core Disabled” and “Trading is currently disabled” on the screen.

      In the CMD window all that appears is a scrolling “Checking core status. Loading config GUI Server deployed ” etc – nothing else

      Any insight as to what is going wrong please ?

      #11462
      Aitor
      Keymaster
        • Posts: 239
        • Administrator

        Hi, first of all, sorry for taking so long to respond. I have had covid and I have been in bed for many days, so I didn’t validate your post until today.

        Responding to your question, “Core disabled” means you don’t have started the bot. Once you access to the GUI, click on “Start Trading” button, then the core will be enabled and the bot will start trading. Remember to have at least one pair added before clicking on “Start Trading” button.

        Gunbot Shop - https://gunbot.shop

        #11531
        Paul Halliday
        Participant
          • Posts: 24
          • Novice

          I am trying to reply to this with a screenshot bit not working. Trading has been enabled but I still get a raft of errors in the command line window

          #11533
          Paul Halliday
          Participant
            • Posts: 24
            • Novice

            I do notice that on the command line it says my registered exchange is Poloniex whereas the exchage I have connected is Okex. In the Edit licence section Poloniex is listed but Okex isnt – is that an issue (it worked befoe

            #11528
            Paul Halliday
            Participant
              • Posts: 24
              • Novice

              Sorry, I that doesn’t work. My sequence is – I click gunthy-win.exe to start the program. A command window opens and the attached screenshot scrolls . Thats it. The second screenshot shows that Trading is enabled but nothing is happening. Last message is Okex timeout Screenshot

               

              #11551
              Aitor
              Keymaster
                • Posts: 239
                • Administrator

                Do you have “Email Listener” enabled?

                Gunbot Shop - https://gunbot.shop

                #11553
                Paul Halliday
                Participant
                  • Posts: 24
                  • Novice

                  No. I am not using TradingView alerts so left that disabled. I’ve never had it enabled even when this was working. I’m totally stuck

                  #11554
                  Aitor
                  Keymaster
                    • Posts: 239
                    • Administrator

                    on the command line it says my registered exchange is Poloniex whereas the exchage I have connected is Okex. In the Edit licence section Poloniex is listed but Okex isnt

                    Send me a PM stating your wallet and Okex api and I will register it properly. It should fix the issue. In the case it doesn’t, I would try updating to a newer bot version as the one you are using is quite old:

                    https://gunbot.shop/category/downloads/

                    Gunbot Shop - https://gunbot.shop

                    #11557
                    Aitor
                    Keymaster
                      • Posts: 239
                      • Administrator

                      Hi, taking a look to the pic you sent me via PM, which shows the complete text of the error, it definitely looks like an API authentification error.

                      Note that Okex asks for 3 things:

                      1- API

                      2- Secret

                      3- Passphrase

                      You need to be sure to add passphrase too. It’s an alphanumerical text you write at the moment of creating the api key. So be sure to save it, and double check everything is correct (no blank spaces, fields are case sensitive etc…).

                      Gunbot Shop - https://gunbot.shop

                      #11559
                      Paul Halliday
                      Participant
                        • Posts: 24
                        • Novice

                        Yes I think you are correct. My API passkey is incorrect & OKX support tell me I can not retrieve it so I have had to set up a new API key and passkey However I have entered these in the Exchanges section on Gunbot but when I start the bot I get a message “Invalid Licence for Okx please contact support”

                        I have tried to get into the “Edit Licence” part of the program but it won’t load localhost:5000 and is all greyed out  Am I able to amend the licence data and and regoster exchanges or do you need to do it – there must be a way for me to add / amend without bothering you

                        I will PM you my new Okx API key

                        I have 5 licence slots – do I need to contact support to add / amend an exchange as it may be useful to have a back up exchange if Okex still fails

                        #11679
                        Aitor
                        Keymaster
                          • Posts: 239
                          • Administrator

                          Hi Paul, sorry for the delay, I need to fix the email alerts when a post is pending for validation, like this case (for posting images or links). I will fix it so I can validate and answer fast. As you say it’s good to have apis of 2 exchanges, so if one of them fails for whatever reason, you can start the bot with the other api.

                          Note that you can set the api / secret directly in the config.js but that api should have been registered before. I mean, if you only have 1 exchange added and your api is “zzz111”, you can’t just put a new api “ppp222” in the config.js file, as the bot won’t recognize it. In that case you can send us an email, or PM in the forum, or just a direct message to my telegram, and I will change it fast for you.

                          As far as you have 1 working api registered, you can add / change any other api yourself.

                          Other important point is that if you change the api from config.js file, and you put a new api and secret, you have to set “isencrypted” to “false”. So it reads your api and secret and after the first run the bot will automatically encrypt the info.

                          Gunbot Shop - https://gunbot.shop

                        Viewing 11 posts - 1 through 11 (of 11 total)
                        • You must be logged in to reply to this topic.
                        Contact us